PEAR::UDDI

Welcome to UDDI!

This documentation was generated by phpDocumentor v1.3.0RC2


Package UDDI Element Index

Element index for package UDDI

Index of all elements
a f g p q s u
top
a
assemble in file UDDI.php, method UDDI::assemble()
generate XML creating the UDDI query
top
f
find_binding in file UDDI.php, method UDDI::find_binding()
Sends find_binding inquiry to UBR (searchs for bindings within a businessService element)
find_business in file UDDI.php, method UDDI::find_business()
Sends find_business inquiry to UBR (searchs businessEntity elements)
find_relatedBusinesses in file UDDI.php, method UDDI::find_relatedBusinesses()
Sends find_relatedBusinesses inquiry to UBR (searchs for related businessEntity elements for a given businessKey)
find_service in file UDDI.php, method UDDI::find_service()
Sends find_service inquiry to UBR (searchs for businessService elements)
find_tModel in file UDDI.php, method UDDI::find_tModel()
Sends find_tModel inquiry to UBR (searchs for tModel elements)
top
g
get_bindingDetail in file UDDI.php, method UDDI::get_bindingDetail()
Sends get_bindingDetail inquiry to UBR (returns bindingDetail elements for one or more bindingKey elements)
get_businessDetail in file UDDI.php, method UDDI::get_businessDetail()
Sends get_businessDetail inquiry to UBR (returns information about one or more businessEntity elements)
get_businessDetailExt in file UDDI.php, method UDDI::get_businessDetailExt()
Sends get_businessDetailExt inquiry to UBR (returns extended information about one or more businessEntity elements)
get_serviceDetail in file UDDI.php, method UDDI::get_serviceDetail()
Sends get_serviceDetail inquiry to UBR (returns information about one or more businessService elements)
get_tModelDetail in file UDDI.php, method UDDI::get_tModelDetail()
Sends get_tModelDetail inquiry to UBR (returns information about one or more tModel elements)
top
p
post in file UDDI.php, method UDDI::post()
assembles HTTP headers and posts these and the UDDI message to the UBR
top
q
query in file UDDI.php, method UDDI::query()
sends and UDDI query to the registry server
top
s
splitUrl in file UDDI.php, method UDDI::splitUrl()
retrieves information from URL and sets params
top
u
UDDI in file UDDI.php, method UDDI::UDDI()
constructor
UDDI in file UDDI.php, class UDDI
UDDI
UDDI.php procedural page UDDI.php
UDDI_PHP_LIB_VERSION in file UDDI.php, constant UDDI_PHP_LIB_VERSION
version of corresponding phpUDDI version


Class Trees for Package UDDI

Root class UDDI
  • PEAR
    • UDDI
Documentation generated on Fri, 9 Apr 2004 17:19:31 +0200 by phpDocumentor 1.3.0RC2


Docs for page UDDI.php

File: /UDDI.php

filesource

Source Code for this file

Classes in this file:

Include Statements Summary

  • require_once = "PEAR.php"

Global Variable Summary

Constant Summary

  • UDDI_PHP_LIB_VERSION = "0.3.1p"
    version of corresponding phpUDDI version

Function Summary

Include Statements Detail

  • require_once file: = "PEAR.php" [line 90]

Global Variable Detail

Constant Detail

  • UDDI_PHP_LIB_VERSION = "0.3.1p" [line 240]

    Remarks

    version of corresponding phpUDDI version

    still included so that moving from phpUDDI to PEAR::UDDI is easier

Function Detail

Documentation generated on Fri, 9 Apr 2004 17:19:31 +0200 by phpDocumentor 1.3.0RC2


File Source for UDDI.php

Source for file UDDI.php

Documentation is available at UDDI.php

1     <?php
2     /* vim: set expandtab tabstop=4 shiftwidth=4: */
3     // +----------------------------------------------------------------------+
4     // | UDDI: A PHP class library implementing the Universal Description,    |
5     // | Discovery and Integration API for locating and publishing Web        |
6     // | Services listings in a UBR (UDDI Business Registry)                  |
7     // +----------------------------------------------------------------------+
8     // | This library is free software; you can redistribute it and/or        |
9     // | modify it under the terms of the GNU Lesser General Public           |
10    // | License as published by the Free Software Foundation; either         |
11    // | version 2.1 of the License, or (at your option) any later version.   |
12    // |                                                                      |
13    // | This library is distributed in the hope that it will be useful,      |
14    // | but WITHOUT ANY WARRANTY; without even the implied warranty of       |
15    // | MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU    |
16    // | General Public License for more details.                             |
17    // |                                                                      |
18    // | You should have received a copy of the GNU General Public License    |
19    // | along with this library; if not, write to the Free Software          |
20    // | Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, |
21    // | USA, or visit http://www.gnu.org/copyleft/gpl.html                   |
22    // +----------------------------------------------------------------------+
23    // | Authors: Jon Stephens & Lee Reynolds (authors of non-PEAR version)   |
24    // |          Maintainers and PEARifiers:                                 |
25    // |          Christian Wenz <chw@hauser-wenz.de>                         |
26    // |          Tobias Hauser <th@hauser-wenz.de>                           |
27    // +----------------------------------------------------------------------+
28    //
29    //    $Id$
30    /* Original Credits:
31
32      phpUDDI
33      A PHP class library implementing the Universal Description,
34      Discovery and Integration API for locating and publishing Web
35      Services listings in a UBR (UDDI Business Registry).
36
37      Copyright (C) 2002-2004 Lee Reynolds and Jon Stephens
38
39      This program is free software; you can redistribute it and/or
40      modify it under the terms of the GNU General Public License
41      as published by the Free Software Foundation; either version 2
42      of the License, or (at your option) any later version.
43
44      This program is distributed in the hope that it will be useful,
45      but WITHOUT ANY WARRANTY; without even the implied warranty of
46      MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
47      GNU General Public License for more details.
48
49      You should have received a copy of the GNU General Public License
50      along with this program; if not, write to the Free Software
51      Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA
52      or point your web browser to http://www.gnu.org/licenses/lgpl.html.
53
54      Conceived and developed in conjunction with the
55      authors' work for the book "PHP Web Services" from Wrox Press
56      Ltd. (ISBN-1861008074)
57
58      Original developers:
59      Lee Reynolds lee@annasart.com
60      Jon Stephens jon@hiveminds.info
61
62      Useful Links:
63
64      Wrox Press "Programmer To Programmer" Discussion Groups
65      Pro PHP: http://p2p.wrox.com/list.asp?list=pro_php
66      Pro XML: http://p2p.wrox.com/list.asp?list=xml
67
68      HiveMinds Group
69      http://www.hiveminds.info/
70      http://forums.hiveminds.info/
71
72      Version History:
73
74      0.1   -- 15 November 2002 -- Basic Proof of concept
75      0.2   -- 20 November 2002 -- Base class redefinition to
76                    include public and private methods
77      0.3   -- 25 November 2002 -- All UDDI 2.0 Inquiry APIs implemented
78      0.3.1 -- 14 March 2004    -- small bugfixes (Christian); license change to LPGL (Lee, Jon)
79
80      Objective for 1.0 release is complete implementation of the UDDI 2.0 API
81      (http://www.uddi.org/pubs/ProgrammersAPI-V2.04-Published-20020719.pdf).
82
83      Objective for 1.5 release is backwards compatibility with UDDI 1.0.
84
85      Objective for 2.0 release is complete implementation of the UDDI 3.0 API
86      (http://www.uddi.org/pubs/uddi-v3.00-published-20020719.pdf).
87
88    */
89
90    require_once "PEAR.php";
91
92    /**
93     * PEAR::UDDI
94     * class that implements the UDDI API
95     * @link http://www.uddi.org/
96     *
97     *  pearified version of phpUDDI by Stephens & Reynolds
98     *
99     *
100    * @category Web Services
101    * @package  UDDI
102    * @version  0.2.0alpha1
103    * @author   Christian Wenz <chw@hauser-wenz.de>
104    * @author   Tobias Hauser <th@hauser-wenz.de>
105    * @todo     fully implement UDDI 2.0 (and later 1.0, 3.0)
106    * @todo     more helper functions (for analyzing the data returned by querying a UBR)
107    * @todo     maybe use more PEAR classes, especially for handling of HTTP requests (but that would make maintaining the PEAR-less version harder)
108   Name:
109     UDDI.php - UDDI Registry access library (PEARified version)
110   Synopsis:
111     require_once 'UDDI.php';
112   Currently, UDDI_base supports 1 function call in one UDDI Api.
113   Variables supported:
114     $UDDI::_api
115     currently 2 values are supported, and they represent 2 of the 6 published APIs by UDDI.org.
116     'Inquiry' which represents the search and _query API
117     'Publish' which represents the publishing API
118     Usage:
119     <code>
120       $UDDI::_api = 'Inquiry'; // (default)
121       $UDDI::_api = 'Publish';
122     </code>
123     $UDDI::_uddiversion
124     This is the API version of the UPI spec you want to use
125     Values are either 1, 2, or 3.
126     Usage:
127     <code>
128       $UDDI::_uddiversion = 2;
129     </code>
130     Default:
131       currently, the version default is '1';
132     Note: As stated above, we are aiming for a 1.0 release of this library which implements
133     the UDDI 2.0 Programming API; we cannot guarantee at this time that any of the API functions
134     as implemented here will work correctly (or at all) unless you set the version to 2 as shown
135     under 'Usage' immediately above or by setting the version when you call the UDDI class constructor:
136     <code>
137     $my_uddi = new UDDI("Microsoft", 2);
138     </code>
139     At a later date we will make this class compatible with UDDI Versions 1.0 and 3.0.
140     $UDDI::_regarray
141     We currently support 2 test registry entries.  These are 'IBM' and 'Microsoft'.
142     We also support 2 API interfaces.. These are, as noted above 'Inquiry', and 'Publish'.
143     To add live registry entries, or your own test registry, you must append a multiple index array element
144     to $UDDI::_regarray.  The form for this follows:
145     <code>
146       array('registry name' =>
147       array('Inquiry' =>
148         array('url' =>'url_for_inquiry',
149           'port' => 80),
150           'Publish' =>
151         array('url'  => 'url_for_publish',
152           'port' => 443)));
153     </code>
154     Internally this is accessed as
155     <code>URL = $_regarray['registry_name']['Inquiry']['url']</code>
156     , and
157     <code>port = $_regarray['registry_name']['Inquiry']['port']</code>
158     PLEASE NOTE: You're adding elements to this array, instead of overwriting old ones.
159     Usage:
160     <code>
161       $UDDI::_regarray = array('private' =>
162                 array('Inquiry' =>
163                 array('url' =>'url_for_inquiry',
164                     'port' => 80),
165                   'Publish' =>
166                 array('url' => 'url_for_publishing',
167                    'port' => 443)));
168     </code>
169     $UDDI::_xmlns
170     You can modify the XML namespace by reassigning a value to this
171     Usage:
172     <code>
173       $UDDI::_xmlns = 'new_ns_definition';
174     </code>
175     Default:
176        "urn:uddi-org:api"
177     $UDDI::_debug
178     Turns on debugging by echoing HTTP headers and UDDI queries.
179     Usage:
180     <code>
181       $UDDI::_debug = TRUE;
182     </code>
183     Default:
184       FALSE
185     $UDDI::_transmit
186     Turns on _posting of UDDI message to UBR.
187     Usage:
188     <code>
189       $UDDI::_transmit = FALSE;
190     </code>
191     Default:
192       TRUE;
193   EXAMPLE:
194   This queries IBM's UDDI Registry for the first 50 businesses whose names include
195   the word "Acme", matches sorted first in ascending order by name, then in descending
196   order by date last updated. The raw XML that's returned is escaped and echoed to the page.
197   <code>
198   $my_uddi = new UDDI("IBM", 1);
199   $result = htmlspecialchars( $my_uddi->find_business(array("name"=>"%Acme%", "maxRows"=>50, "findQualifiers"=>"sortByNameAsc,sortByDateAsc") ) );
200   echo "<pre>$result</pre>"
201   </code>
233   */
234
235   /**
236    * version of corresponding phpUDDI version
237    * still included so that moving from phpUDDI to PEAR::UDDI is easier
238    */
239
240   define("UDDI_PHP_LIB_VERSION", "0.3.1p"); //suffix p = PEAR :-)
241
242   /**
243    * UDDI
244    *
245    * class that implements the UDDI API
246    *
247    * @package  UDDI
248    * @author   Christian Wenz <chw@hauser-wenz.de>
249    * @author   Tobias Hauser <th@hauser-wenz.de>
250   */
251   class UDDI extends PEAR
252   {
253      /**
254       * version of package
255       * @var string $_version
256       */
257       var $_version = "0.2.0alpha1";
258
259      /**
260       * list of known registries
261       * @var array $regarray
262       */
263
264       var $_regarray =
265           array('IBM' =>
266               array('Inquiry'  =>
267                   array('url'  => "www-3.ibm.com/services/uddi/testregistry/inquiryapi",
268                       'port' => 80),
269               'Publish' =>
270                   array('url' => "https://www-3.ibm.com/services/uddi/testregistry/protect/publishapi",
271                       'port' => 443)),
272
273               'Microsoft' =>
274                   array('Inquiry'  =>
275                       array('url'  =>"test.uddi.microsoft.com/inquire",
276                           'port' => 80),
277               'Publish' =>
278                   array('url' =>"https://test.uddi.microsoft.com/publish",
279                       'port' => 443)));
280
281
282      /**
283       * which API to use (Inquiry/Publish)
284       * @var string $_api
285       */
286       var $_api       = "Inquiry";
287
288      /**
289       * used XML namespace
290       * @var string $_xmlns
291       */
292       var $_xmlns    = "urn:uddi-org:api";
293
294      /**
295       * used UDDI version
296       * @var string $_uddiversion
297       */
298       var $_uddiversion  = 1;
299
300      /**
301       * used XML generic version
302       * @var string $_generic
303       */
304       var $_generic;
305
306      /**
307       * debug mode
308       * @var boolean $_debug
309       */
310       var $_debug    = FALSE;
311
312      /**
313       * Turns on _posting of UDDI message to UBR
314       * @var boolean $_transmit
315       */
316       var $_transmit = TRUE;
317
318      /**
319       * Host to use
320       * @var string $_host
321       */
322       var $_host;
323
324      /**
325       * URL to use
326       * @var string $_url
327       */
328       var $_url;
329
330      /**
331       * constructor
332       *
333       * @access   public
334       * @param    string   $registry    name of registry to use
335       * @param    integer  $version     UDDI version to use
336       */
337       function UDDI($registry='IBM', $version=1)
338       {
339           $this->splitUrl($registry, $version);
340       }
341
342      /**
343       * retrieves information from URL and sets params
344       *
345       * @access   public
346       * @param    string   $registry    name of registry to use
347       * @param    integer  $version     UDDI version to use
348       */
349       function splitUrl($registry, $version)
350       {
351           $this->_registry = $registry;
352           $reg = $this->_regarray[$this->_registry][$this->_api]['url'];
353           $reg = str_replace("http://", "", $reg);
354           $pos = strpos($reg, '/')
355               or PEAR::raiseError("Invalid registry POS = $pos, URL = '$reg'\n");
356           $this->_host = substr($reg, 0, $pos);
357           $this->_url = substr($reg, $pos, strlen($reg)-1);
358
359           if ($version>1) {
360               $this->_xmlns .= "_v$version";
361           }
362
363           $this->_generic = "$version.0";
364       }
365
366      /**
367       * assembles HTTP headers and posts these and the UDDI message to the UBR
368       *
369       * @access   public
370       * @param    string  $message    the UDDI message to send
371       * @return   string  $data       data returned from the UBR
372       */
373       function post( $message )
374       {
375           $msg_length = strlen( $message );
376           $php_version = phpversion();
377           $date = str_replace( "+0000", "GMT", gmdate("r", time()) );
378
379           $header = "";
380           $header .= "POST $this->_url HTTP/1.0\r\n";
381           $header .= "Date: $date\r\n";
382           $header .= "Content-Type: text/xml; charset=UTF-8\r\n";
383           $header .= "User-agent: PEAR::UDDI/$this->_version php/$php_version\r\n";
384           $header .= "Host: $this->_host\r\n";
385           $header .= "SOAPAction: \"\"\r\n";
386           $header .= "Content-Length: $msg_length\r\n\r\n";
387
388           //  echoes HTTP header and UDDI message to page if true
389           if ($this->_debug) {
390               echo "<pre>" . htmlspecialchars( str_replace("><", ">\n<", $header . $message) ) . "</pre>";
391           }
392
393           //  sends header and message to UBR if true
394           if ($this->_transmit) {
395               $port = $this->_regarray[$this->_registry][$this->_api]['port'];
396               $fp = fsockopen($this->_host, $port, $errno, $errstr, 5)
397                   or PEAR::raiseError("Couldn't connect to server at $this->_host:$port.<br />Error #$errno: $errstr.");
398
399               fputs($fp, $header)
400                   or PEAR::raiseError("Couldn't send HTTP headers.");
401               fputs($fp, "$message\n\n")
402                   or PEAR::raiseError("Couldn't send UDDI message.");
403
404               $response = "";
405               while (!feof($fp)) {
406                   $response .= fgets($fp, 1024)
407                       or PEAR::raiseError("No response from server.");
408               }
409               fclose($fp)
410                   or PEAR::raiseError("Warning: Couldn't close HTTP connection.");
411
412               $response = str_replace("><", ">\n<", $response);
413               return $response;
414           }
415       }
416
417      /**
418       * sends and UDDI query to the registry server
419       *
420       * @access   public
421       * @param    string  $method     the UDDI message to send
422       * @param    array   $params     parameters for the query
423       * @return   string  $data       response from the registry server
424       */
425       function query($method, $params)
426       {
427           $message = $this->assemble($method, $params);
428
429           return $this->post( $message );
430       }
431
432      /**
433       * generate XML creating the UDDI query
434       *
435       * @access   public
436       * @param    string  $method     the UDDI message to send
437       * @param    array   $params     parameters for the query
438       * @return   string  $data       the desired XML query code
439       */
440       function assemble($method, $params)
441       {
442           $head = "<?xml version=\"1.0\" encoding=\"utf-8\"?>";
443           $head .= "<Envelope xmlns=\"http://schemas.xmlsoap.org/soap/envelope/\">";
444           $head .= "<Body>";
445
446           $end = "</$method></Body></Envelope>";
447
448           $attrib = "";
449           $element = "";
450
451
452           if (isset($params['discoveryURLs']) && ($params['discoveryURLs'] != '')) {
453               $element .= "<discoveryURLs>" . $params['discoveryURLs'] . "</discoveryURLs>";
454           }
455
456           if (isset($params['bindingKey']) && ($params['bindingKey'] != '')) {
457               $element .= "<bindingKey>" . $params['bindingKey'] . "</bindingKey>";
458           }
459
460           if (isset($params['businessKey']) && ($params['businessKey'] != '')) {
461               $element .= "<businessKey>" . $params['businessKey'] . "</businessKey>";
462           }
463
464           if (isset($params['serviceKey']) && ($params['serviceKey'] != '')) {
465
466               if ($method == "find_binding") {
467                   $attrib .= " serviceKey=\"" . $params['serviceKey'] . "\"";
468               }
469               if ($method == "get_serviceDetail") {
470                   $element .= "<serviceKey>" . $params['serviceKey'] . "</serviceKey>";
471               }
472           }
473
474
475           if (isset($params['tModelKey']) && ($params['tModelKey'] != '')) {
476               $element .= "<tModelKey>uuid:" . $params['tModelKey'] . "</tModelKey>";
477           }
478
479           if (isset($params['findQualifiers']) && ($params['findQualifiers'] != '')) {
480               $element .= "<findQualifiers>";
481               $findQualifiers = explode(',', $params['findQualifiers']);
482               for ($i=0; $i<count($findQualifiers); $i++) {
483                   $element .= "<findQualifier>" . $findQualifiers[$i] . "</findQualifier>";
484               }
485               $element .= "</findQualifiers>";
486           }
487
488           if (isset($params['tModelBag']) && ($params['tModelBag'] != '')) {
489               $tModelKey = explode(',', $params['tModelBag']);
490               $element .= "<tModelBag>";
491               for ($i=0; $i<count($tModelKey); $i++) {
492                   $element .= "<tModelKey>uuid:" . $tModelKey[$i] . "</tModelKey>";
493                   $element .= "</tModelBag>";
494               }
495           }
496
497           if (isset($params['name']) && ($params['name'] != '')) {
498               $lang = '';
499               if (isset($params['lang']) && ($params['lang'] != '')) {
500                   $lang = "xml:lang=\"" . $lang . "\"";
501               }
502               $element .= "<name $lang>" . $params['name'] . "</name>";
503           }
504
505           if (isset($params['identifierBag']) && ($params['identifierBag'] != '')) {
506               $element .= "<identifierBag>";
507               $keyedReference = explode(',', $params['identifierBag']);
508               for ($i=0; $i<count( $keyedReference ); $i++) {
509                   $element .= "<keyedReference>" . $keyedReference[$i] . "</keyedReference>";
510               }
511               $element .= "</identifierBag>";
512           }
513
514           if (isset($params['categoryBag']) && ($params['categoryBag'] != '')) {
515               $element .= "<categoryBag>";
516               $keyedReference = explode(',', $params['identifierBag']);
517               for ($i=0; $i<count( $keyedReference ); $i++) {
518                   $element .= "<keyedReference>" . $keyedReference[$i]
519                                                           . "</keyedReference>";
520               }
521               $element .= "</categoryBag>";
522           }
523
524           if (isset($params['maxRows']) && ($params['maxRows'] != '')) {
525               $attrib .= " maxRows=\"" . $params['maxRows'] . "\"";
526           }
527
528           $head .= "<$method $attrib xmlns=\"$this->_xmlns\" generic=\"$this->_generic\">";
529
530           $message = $head;
531           $message .= $element;
532           $message .= $end;
533
534           return $message;
535       }
536
537      /**
538       * Sends find_binding inquiry to UBR (searchs for bindings within a businessService element)
539       *
540       * @access   public
541       * @param    array   $params     parameters for the query
542       * @return   string  $data       response from the registry server
543       */
544       function find_binding($params)
545       {
546           $data = $this->query("find_binding", $params);
547           return $data;
548       }
549
550      /**
551       * Sends find_business inquiry to UBR (searchs businessEntity elements)
552       *
553       * @access   public
554       * @param    array   $params     parameters for the query
555       * @return   string  $data       response from the registry server
556       */
557       function find_business($params)
558       {
559           $data = $this->query("find_business", $params);
560           return $data;
561       }
562
563      /**
564       * Sends find_relatedBusinesses inquiry to UBR (searchs for related businessEntity elements for a given businessKey)
565       *
566       * @access   public
567       * @param    array   $params     parameters for the query
568       * @return   string  $data       response from the registry server
569       */
570       function find_relatedBusinesses($params)
571       {
572           $data = $this->query("find_relatedBusinesses", $params);
573           return $data;
574       }
575
576      /**
577       * Sends find_service inquiry to UBR (searchs for businessService elements)
578       *
579       * @access   public
580       * @param    array   $params     parameters for the query
581       * @return   string  $data       response from the registry server
582       */
583       function find_service($params)
584       {
585           $data = $this->query("find_service", $params);
586           return $data;
587       }
588
589      /**
590       * Sends find_tModel inquiry to UBR (searchs for tModel elements)
591       *
592       * @access   public
593       * @param    array   $params     parameters for the query
594       * @return   string  $data       response from the registry server
595       */
596       function find_tModel($params)
597       {
598           $data = $this->query("find_tModel", $params);
599           return $data;
600       }
601
602      /**
603       * Sends get_bindingDetail inquiry to UBR (returns bindingDetail elements for one or more bindingKey elements)
604       *
605       * @access   public
606       * @param    array   $params     parameters for the query
607       * @return   string  $data       response from the registry server
608       */
609       function get_bindingDetail($params)
610       {
611           $data = $this->query("get_bindingDetail", $params);
612           return $data;
613       }
614
615      /**
616       * Sends get_businessDetail inquiry to UBR (returns information about one or more businessEntity elements)
617       *
618       * @access   public
619       * @param    array   $params     parameters for the query
620       * @return   string  $data       response from the registry server
621       */
622       function get_businessDetail($params)
623       {
624           $data = $this->query("get_businessDetail", $params);
625           return $data;
626       }
627
628      /**
629       * Sends get_businessDetailExt inquiry to UBR (returns extended information about one or more businessEntity elements)
630       *
631       * @access   public
632       * @param    array   $params     parameters for the query
633       * @return   string  $data       response from the registry server
634       */
635       function get_businessDetailExt($params)
636       {
637           $data = $this->query("get_businessDetailExt", $params);
638           return $data;
639       }
640
641      /**
642       * Sends get_serviceDetail inquiry to UBR (returns information about one or more businessService elements)
643       *
644       * @access   public
645       * @param    array   $params     parameters for the query
646       * @return   string  $data       response from the registry server
647       */
648       function get_serviceDetail($params)
649       {
650           $data = $this->query("get_serviceDetail", $params);
651           return $data;
652       }
653
654      /**
655       * Sends get_tModelDetail inquiry to UBR (returns information about one or more tModel elements)
656       *
657       * @access   public
658       * @param    array   $params     parameters for the query
659       * @return   string  $data       response from the registry server
660       */
661       function get_tModelDetail($params)
662       {
663           $data = $this->query("get_tModelDetail", $params);
664           return $data;
665       }
666   }
667   ?>


Docs For Class UDDI

Class UDDI

[line 251]
PEAR
   |
   --UDDI
Location: /UDDI.php

Remarks

UDDI

class that implements the UDDI API

author

Christian Wenz <chw@hauser-wenz.de>

author

Tobias Hauser <th@hauser-wenz.de>

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • UDDI UDDI()
    constructor
  • string assemble()
    generate XML creating the UDDI query
  • string find_binding()
    Sends find_binding inquiry to UBR (searchs for bindings within a businessService element)
  • string find_business()
    Sends find_business inquiry to UBR (searchs businessEntity elements)
  • string find_relatedBusinesses()
    Sends find_relatedBusinesses inquiry to UBR (searchs for related businessEntity elements for a given businessKey)
  • string find_service()
    Sends find_service inquiry to UBR (searchs for businessService elements)
  • string find_tModel()
    Sends find_tModel inquiry to UBR (searchs for tModel elements)
  • string get_bindingDetail()
    Sends get_bindingDetail inquiry to UBR (returns bindingDetail elements for one or more bindingKey elements)
  • string get_businessDetail()
    Sends get_businessDetail inquiry to UBR (returns information about one or more businessEntity elements)
  • string get_businessDetailExt()
    Sends get_businessDetailExt inquiry to UBR (returns extended information about one or more businessEntity elements)
  • string get_serviceDetail()
    Sends get_serviceDetail inquiry to UBR (returns information about one or more businessService elements)
  • string get_tModelDetail()
    Sends get_tModelDetail inquiry to UBR (returns information about one or more tModel elements)
  • string post()
    assembles HTTP headers and posts these and the UDDI message to the UBR
  • string query()
    sends and UDDI query to the registry server
  • void splitUrl()
    retrieves information from URL and sets params

Inherited Method Summary

Method Detail

    UDDI::UDDI

    UDDI( [string $registry = 'IBM'], [integer $version = 1] );

    Parameters

    $registry

    name of registry to use

    $version

    UDDI version to use

    Remarks

    constructor

    access

    public

    [ Top ]

    UDDI::assemble

    assemble( string $method, array $params );

    Parameters

    $method

    the UDDI message to send

    $params

    parameters for the query

    Returns

    the desired XML query code

    Remarks

    generate XML creating the UDDI query

    access

    public

    [ Top ]

    UDDI::find_binding

    find_binding( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends find_binding inquiry to UBR (searchs for bindings within a businessService element)

    access

    public

    [ Top ]

    UDDI::find_business

    find_business( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends find_business inquiry to UBR (searchs businessEntity elements)

    access

    public

    [ Top ]

    UDDI::find_relatedBusinesses

    find_relatedBusinesses( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends find_relatedBusinesses inquiry to UBR (searchs for related businessEntity elements for a given businessKey)

    access

    public

    [ Top ]

    UDDI::find_service

    find_service( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends find_service inquiry to UBR (searchs for businessService elements)

    access

    public

    [ Top ]

    UDDI::find_tModel

    find_tModel( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends find_tModel inquiry to UBR (searchs for tModel elements)

    access

    public

    [ Top ]

    UDDI::get_bindingDetail

    get_bindingDetail( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends get_bindingDetail inquiry to UBR (returns bindingDetail elements for one or more bindingKey elements)

    access

    public

    [ Top ]

    UDDI::get_businessDetail

    get_businessDetail( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends get_businessDetail inquiry to UBR (returns information about one or more businessEntity elements)

    access

    public

    [ Top ]

    UDDI::get_businessDetailExt

    get_businessDetailExt( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends get_businessDetailExt inquiry to UBR (returns extended information about one or more businessEntity elements)

    access

    public

    [ Top ]

    UDDI::get_serviceDetail

    get_serviceDetail( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends get_serviceDetail inquiry to UBR (returns information about one or more businessService elements)

    access

    public

    [ Top ]

    UDDI::get_tModelDetail

    get_tModelDetail( array $params );

    Parameters

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    Sends get_tModelDetail inquiry to UBR (returns information about one or more tModel elements)

    access

    public

    [ Top ]

    UDDI::post

    post( string $message );

    Parameters

    $message

    the UDDI message to send

    Returns

    data returned from the UBR

    Remarks

    assembles HTTP headers and posts these and the UDDI message to the UBR

    access

    public

    [ Top ]

    UDDI::query

    query( string $method, array $params );

    Parameters

    $method

    the UDDI message to send

    $params

    parameters for the query

    Returns

    response from the registry server

    Remarks

    sends and UDDI query to the registry server

    access

    public

    [ Top ]

    UDDI::splitUrl

    splitUrl( string $registry, integer $version );

    Parameters

    $registry

    name of registry to use

    $version

    UDDI version to use

    Remarks

    retrieves information from URL and sets params

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Fri, 9 Apr 2004 17:19:31 +0200 by phpDocumentor 1.3.0RC2


Element Index

Index of All Elements

Indexes by package:
UDDI

a f g p s
top
a
assemble in file UDDI.php, method UDDI::assemble()
generate XML creating the UDDI query
top
f
find_binding in file UDDI.php, method UDDI::find_binding()
Sends find_binding inquiry to UBR (searchs for bindings within a businessService element)
find_business in file UDDI.php, method UDDI::find_business()
Sends find_business inquiry to UBR (searchs businessEntity elements)
find_relatedBusinesses in file UDDI.php, method UDDI::find_relatedBusinesses()
Sends find_relatedBusinesses inquiry to UBR (searchs for related businessEntity elements for a given businessKey)
find_service in file UDDI.php, method UDDI::find_service()
Sends find_service inquiry to UBR (searchs for businessService elements)
find_tModel in file UDDI.php, method UDDI::find_tModel()
Sends find_tModel inquiry to UBR (searchs for tModel elements)
top
g
get_bindingDetail in file UDDI.php, method UDDI::get_bindingDetail()
Sends get_bindingDetail inquiry to UBR (returns bindingDetail elements for one or more bindingKey elements)
get_businessDetail in file UDDI.php, method UDDI::get_businessDetail()
Sends get_businessDetail inquiry to UBR (returns information about one or more businessEntity elements)
get_businessDetailExt in file UDDI.php, method UDDI::get_businessDetailExt()
Sends get_businessDetailExt inquiry to UBR (returns extended information about one or more businessEntity elements)
get_serviceDetail in file UDDI.php, method UDDI::get_serviceDetail()
Sends get_serviceDetail inquiry to UBR (returns information about one or more businessService elements)
get_tModelDetail in file UDDI.php, method UDDI::get_tModelDetail()
Sends get_tModelDetail inquiry to UBR (returns information about one or more tModel elements)
top
p
post in file UDDI.php, method UDDI::post()
assembles HTTP headers and posts these and the UDDI message to the UBR
top
q
query in file UDDI.php, method UDDI::query()
sends and UDDI query to the registry server
top
s
splitUrl in file UDDI.php, method UDDI::splitUrl()
retrieves information from URL and sets params
top
u
UDDI in file UDDI.php, method UDDI::UDDI()
constructor
UDDI in file UDDI.php, class UDDI
UDDI
UDDI.php procedural page UDDI.php
UDDI_PHP_LIB_VERSION in file UDDI.php, constant UDDI_PHP_LIB_VERSION
version of corresponding phpUDDI version


phpDocumentor Parser Errors and Warnings

 Post-parsing

Post-parsing

Warnings:

Warning - Class UDDI parent PEAR not found

UDDI.php

Warnings:

Warning on line 256 - class variable "UDDI::$_version" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 278 - class variable "UDDI::$_regarray" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 285 - class variable "UDDI::$_api" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 291 - class variable "UDDI::$_xmlns" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 297 - class variable "UDDI::$_uddiversion" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 303 - class variable "UDDI::$_generic" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 309 - class variable "UDDI::$_debug" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 315 - class variable "UDDI::$_transmit" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 321 - class variable "UDDI::$_host" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 327 - class variable "UDDI::$_url" is assumed to be @access private because its name starts with _, but has no @access tag
Warning on line 666 - File "C:\TRANSFER\UDDI.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Documentation generated on Fri, 9 Apr 2004 17:19:32 +0200 by phpDocumentor 1.3.0RC2